about summary refs log tree commit diff
path: root/gopher-proxy.nix
diff options
context:
space:
mode:
Diffstat (limited to 'gopher-proxy.nix')
-rw-r--r--gopher-proxy.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/gopher-proxy.nix b/gopher-proxy.nix
new file mode 100644
index 0000000..9d8e448
--- /dev/null
+++ b/gopher-proxy.nix
@@ -0,0 +1,17 @@
+{ mkDerivation, attoparsec, base, bytestring, errors, http-types
+, lucid, mime-types, network, optparse-applicative
+, optparse-generic, stdenv, text, wai, warp
+}:
+mkDerivation {
+  pname = "gopher-proxy";
+  version = "0.1.0.0";
+  src = ./.;
+  isLibrary = false;
+  isExecutable = true;
+  executableHaskellDepends = [
+    attoparsec base bytestring errors http-types lucid mime-types
+    network optparse-applicative optparse-generic text wai warp
+  ];
+  description = "proxy gopher over http";
+  license = stdenv.lib.licenses.gpl3;
+}