about summary refs log tree commit diff
path: root/logbook.nix
diff options
context:
space:
mode:
Diffstat (limited to 'logbook.nix')
-rw-r--r--logbook.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/logbook.nix b/logbook.nix
index 8266f1e..dc3f548 100644
--- a/logbook.nix
+++ b/logbook.nix
@@ -11,7 +11,10 @@ buildDunePackage rec {
   propagatedBuildInputs = [ ptime angstrom astring ];
 
   postBuild = "dune build @doc";
-  postInstall = "cp -r _build/default/_doc/_html $out/doc/logbook/html";
+  postInstall = ''
+    mkdir -p $out/doc/logbook/html
+    cp -r _build/default/_doc/_html/* $out/doc/logbook/html
+  '';
 
   useDune2 = true;
 }